/ / Net SNMP-Daemon startet nicht - debian, snmp

Net SNMP-Daemon startet nicht - Debian, SNMP

Ich hatte es jahrelang perfekt funktionieren, aber plötzlich (ich denke, es folgt dem Debian 8 -> Debian 9 Upgrade) hörte es auf zu funktionieren.

Ich habe verschiedene Dinge ausprobiert und am Ende alles gelöscht:

# apt purge snmp snmpd

und dann neu installiert, aber es funktioniert immer noch nicht.

Ich starte es mit systemd (auch wenn es in ist) /etc/init.d) mit

# systemctl start snmpd

Ich sehe, dass der Prozess mit den folgenden Optionen gestartet wird:

/usr/sbin/snmpd -Lsd -Lf /dev/null -u Debian-snmp -g Debian-snmp -I -smux mteTrigger mteTriggerConf -f

Hier ist der Daemon-Status:

# systemctl status snmpd
‚óŹ snmpd.service - Simple Network Management Protocol (SNMP) Daemon.
Loaded: loaded (/lib/systemd/system/snmpd.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2017-09-17 12:59:43 CEST; 5min ago
Process: 58656 ExecStartPre=/bin/mkdir -p /var/run/agentx (code=exited, status=0/SUCCESS)
Main PID: 58659 (snmpd)
Tasks: 1 (limit: 9830)
Memory: 5.9M
CPU: 27ms
CGroup: /system.slice/snmpd.service
‚ĒĒ‚ĒÄ58659 /usr/sbin/snmpd -Lsd -Lf /dev/null -u Debian-snmp -g Debian-snmp -I -smux mteTrigger mteTriggerConf -f

Sep 17 12:59:43 dikkenek systemd[1]: Starting Simple Network Management Protocol (SNMP) Daemon....
Sep 17 12:59:43 dikkenek systemd[1]: Started Simple Network Management Protocol (SNMP) Daemon..
Sep 17 12:59:43 dikkenek snmpd[58659]: error on subcontainer "ia_addr" insert (-1)

Ich habe auch gesehen, dass der Benutzer von ge√§ndert wurde snmp zu Debian-snmp. Ich pers√∂nlich halte das f√ľr eine bl√∂de Ver√§nderung, aber am Ende ist es mir eigentlich egal. Ich wei√ü nicht, ob es die Ursache meines Problems ist.

Das eigentliche Problem ist:

  • Ich kann den Prozess nicht stoppen oder t√∂ten, ich muss mit t√∂ten -9 damit es aufh√∂rt
  • Wenn ich den Vorgang von Hand starte, ist die Shell gesperrt und reagiert nicht auf Strg-C, Strg-Z usw
  • Der UDP-Port ist nicht ge√∂ffnet, z. lsof -i udp:161 gibt nichts zur√ľck
  • beim Versuch, es zu stoppen (z. systemctl stop snmpd) es h√§ngt und ich muss eigentlich pkill -9 snmpd erholen

Ich habe das √ľberpr√ľft:

  • Iptables erm√∂glicht den Verkehr
  • Die Konfigurationsdateien sind Standard
  • Die Konferenz sagt, es sollte localhost h√∂ren: 161
  • Starten Sie es mit -LS7d ergibt in syslog nichts interessantes (gleiche Ausgabe wie die systemctl status Ausgabe oben)

Jeder Versuch, eine Version oder Community abzurufen oder darauf zuzugreifen, f√ľhrt zu einem Timeout-Fehler.

Ich weiß nicht, was passiert ist und wie ich es wieder auf die Beine bekomme.

Antworten:

0 f√ľr Antwort ‚ĄĖ 1

Ich habe ein falsches NFS-Mount, das aus irgendeinem Grund vom SNMP-Daemon gescannt wurde.

Ich habe autofs gestoppt, faul die gefälschten NFS-Freigaben gemountet und SNMPd neu gestartet.

Ich könnte das finden, indem ich SNMP spanne:

strace snmpd

Es steckte fest stat auf der falschen NFS-Freigabe.